Installation

WfCommons is available on PyPI. WfCommons requires Python3.6+ and has been tested on Linux and macOS.

Requirements

Graphviz

WfCommons uses pygraphviz and thus needs the graphviz package installed (version 2.16 or later). You can install graphviz easily on Linux with your favorite package manager, for example for Debian-based distributions:

$ sudo apt-get install graphviz libgraphviz-dev

and for RedHat-based distributions:

$ sudo yum install python-devel graphviz-devel

On macOS you can use the brew package manager:

$ brew install graphviz

Installation using pip

While pip can be used to install WfCommons, we suggest the following approach for reliable installation when many Python environments are available:

$ python3 -m pip install workflowhub

Retrieving the latest unstable version

If you want to use the latest WfCommons unstable version, that will contain brand new features (but also contain bugs as the stabilization work is still underway), you may consider retrieving the latest unstable version.

Cloning from WfCommons’s GitHub repository:

$ git clone https://github.com/wfcommons/wfcommons
$ cd wfcommons
$ pip install .